Custom Search . . .

Wednesday, September 10, 2008

Upgrade Oracle from 10.2.0.1 To 10.2.0.4

1. Patch Set Overview

Patch set release 10.2.0.4. Before installing this patch set you must be need 10.2.0.1 version.

2. Requirements

Oracle DB : Oracle 10.2.0.1 (later)
Operating System: Windows


3. Pre - Installation Tasks

1. Identify prior installation

Before installing this patch you must install oracle 10.2.0.1 (or later version)

2. Download Patch set

Download 6810189 patch set installation archive to a directory that is not the Oracle home directory or under the Oracle home directory.

3. Shutdown oracle database.

C:\>set oracle_sid= GOLDLINK

C:\>sqlplus /nolog

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Nov 13 10:49:26 2007

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SQL> connect sys@GOLDLINK as sysdba
Enter password:
Connected.

SQL> SHUTDOWN
Database closed.
Database dismounted.
ORACLE instance shut down.

4. Stop all services

C:\>set oracle_sid=GoldLink

C:\>net stop OracleDBConsoleGOLDLINK
The OracleDBConsoleGOLDLINK service is stopping................
The OracleDBConsoleGOLDLINK service was stopped successfully.


C:\>net stop OracleServiceGOLDLINK
The OracleServiceGOLDLINK service is stopping.
The OracleServiceGOLDLINK service was stopped successfully.


C:\>net stop OracleOraDB10g_Home1iSQL*Plus..
The OracleOraDb10g_home1iSQL*Plus service was stopped successfully.

C:\>net stop OracleOraDB10g_Home1TNSListener
The OracleOraDb10g_home1TNSListener service is stopping.
The OracleOraDb10g_home1TNSListener service was stopped successfully.

Note: while patch installation time If you face Distributed Transaction Coordinator still running. You should be stop this service

C:\>net stop msdtc
The Distributed Transaction Coordinator service is stopping.
The Distributed Transaction Coordinator service was stopped successfully.

4. Backup your database.

Oracle recommends that you create a backup of the Oracle 10g installation before you install the patch set.

5. Check Tablespace Sizes and Set Parameter Values

Review the following sections before upgrading a database.

8. Upgrade the Database

After you install the patch set, you must perform the following steps on every database associated with the upgraded Oracle home:

1. Start all services


2. Connect sys user

C:\> sqlplus /NOLOG

SQL> CONNECT SYS/SYS_password AS SYSDBA

3. Enter the following SQL*Plus commands:

SQL> STARTUP UPGRADE

SQL> SPOOL patch.log

SQL> @ORACLE_BASE\ORACLE_HOME\rdbms\admin\catupgrd.sql

SQL> SPOOL OFF

Review the patch.log file for errors and inspect the list of components that is displayed at the end of catupgrd.sql script.

This list provides the version and status of each SERVER component in the database.

If necessary, rerun the catupgrd.sql script after correcting any problems.

4. Restart the database:


SQL> SHUTDOWN
SQL> STARTUP

5. Compile Invalid Objects

Run the utlrp.sql script to recompile all invalid PL/SQL packages now instead of when the packages are accessed for the first time. This step is optional but recommended.

SQL> @ORACLE_BASE\ORACLE_HOME\rdbms\admin\utlrp.sql

SQL> select * from v$version;

BANNER
----------------------------------------------------------------
Oracle Database 10g Release 10.2.0.4.0 - Production
PL/SQL Release 10.2.0.4.0 - Production
CORE 10.2.0.4.0 Production
TNS for 32-bit Windows: Version 10.2.0.4.0 - Production
NLSRTL Version 10.2.0.4.0 - Production

43 comments:

Anonymous said...

Very helpful. Thanks.

Anonymous said...

Very helpful. Thanks.

Anonymous said...

Very nice instructions.
Went through so many links before
all are confusing..

Thanks!

Babu B said...

Thank a lot.. :-)

Babu

Aditya said...

Thanks a lot...

Anonymous said...

Babu,
Do i have to install oracle 10204 in another home?

Babu B said...

Hi,

Thanks.

NO NO; You need to install same ORACLE_HOME before that need to down all oracle related services.

Could you tel me which operating system your going to install (Win or Linux/Unix ??)

Babu

Anonymous said...

Hi Babu,

I want to upgrade 10.2.0.2 database to 10.2.0.4. for which i installed binaries of 10.2.0.4 in seperate directory.

2.) now changed environment variables for this oracle sid to point to new directory (oracle home of 10.2.0.4).

3.) Now while doing startup upgrade, it fails with the following error:

SQL> startup upgrade;
ORA-00401: the value for parameter compatible is not supported by this release

Value of compatible parameter in init.ora file is set to 10.2.0.2
compatible=10.2.0.2

Any ideas, what can be the issue?

john said...

Thank you for these simple instructions Babu. All worked fine.

kumaran said...

Hi Babu,

I found the upgrade steps are missing in the document(steps 6 ,7).

Kindly provide me the instruction to upgrade from win Oracle 10.2.0.2 to 10.2.0.4.

Awaiting for your kind reply

Thanks,
Kumaran

Babu B said...

>>Kindly provide me the instruction to upgrade from win Oracle 10.2.0.2 to 10.2.0.4.

NO all the steps are available. From where your Straggling upgrade steps??

Thanks

Babu

Babu B said...

Thanks John :)

Babu B said...

>>
I want to upgrade 10.2.0.2 database to 10.2.0.4. for which i installed binaries of 10.2.0.4 in seperate directory.

You you want separate directory installation??

Post your current database version using

select * from v$version;

show parameter compatible

Let me know your patch number

Thanks

Anonymous said...

hi babu,

how to proceed , if already i have two db's running on 10.2.0.2 in unix.

Babu B said...

If two database running same home; you need to upgrade both database.

Thanks

Júlio César Corrêa said...

This post was helpful.
Thanks.
JC

Júlio César Corrêa said...

this post was helpful.

Thanks a lot.

JC

Babu B said...

Thanks for your feedback.

Babu

Anonymous said...

Hi thanks for this, but after upgrading I found that I could not take exports and found the answer

http://oracle-in-examples.blogspot.com/2008/03/exp-00008-oracle-error-6550-encountered.html

here is a part of that post

. . exporting table DEF$_ERROR
EXP-00008: ORACLE error 6510 encountered
ORA-06510: PL/SQL: unhandled user-defined exception
ORA-06512: at "SYS.DBMS_EXPORT_EXTENSION", line 50
ORA-06512: at "SYS.DBMS_EXPORT_EXTENSION", line 126
ORA-06512: at line 1
. . exporting table DEF$_LOB 0 rows exported
...

I have found that we need to grant some sys procedures to this user for getting rid of these errors.
So I logged in as sys and executed the following commands:
GRANT EXECUTE ON SYS.DBMS_DEFER_IMPORT_INTERNAL TO ;
GRANT EXECUTE ON SYS.DBMS_EXPORT_EXTENSION TO ;
And it really helped me to fix it.

Thanks,
Sergey.

Thanks

Best regards

Anonymous said...

Hello, Babu,

.....
4. Backup your database.
5. Check Tablespace Sizes and Set Parameter Values

8. Upgrade the Database

.....

Wondering where are step 6 and 7 ?

Do we supposed to install the setup.exe before step 8 ?

Please advice. Thanks so much !

Babu said...

>>Wondering where are step 6 and 7 ?

Do we supposed to install the setup.exe before step 8 ?

Thanks for chatching. Yes after step 5; execute setup.exe before step 8

let me if you need any help.

Thanks

Sunil said...

Really helpful ..........

Anonymous said...

Com um procedimento assim, fica muito facil. Muito bom. Obrigado.

Khaja said...

Do you have any info on how to upgrade from 10.2.0.1 to 11g.? I get an error "The CEP file rdbmsup.sql does not provide the version directive."? Any idea what is causing this..

Babu said...

Hello Khaja,

Upgrade your 10g database to 10.2.0.4,

Then try to upgrade 10.2.0.4 to 11g.

http://download.oracle.com/docs/cd/E11882_01/server.112/e10819/preup.htm#i1007753

Babu

kamlesh said...

Dear Babu,
I have installed Oracle 10g (10.1.0.2.0) on vista machine 32 Bit but i m not able to open SQL successfully. It gives different error like :
ORA-12154: TNS:could not resolve the connect identifier specified.
Actually it gives an TNS entry error while configuration the database.
So, please guide me for this problem or provide me any setting on Vista so i can install properly.
Thanks and regards,
Kamlesh Parmar
kamalerp53@gmail.com

Babu said...

Hello Kamlesh,

Thanks for your input.

I would like your TSNPING output. Pls post TNSPIGN <> 5

Are you trying to connect database locally or remotely?

Babu

Indian said...

Thanks for this ,

I want to know after upgrading to 10.2.0.4 what are the issues we get commonly . then only i would like to upgrade..

please replay me ASAP.

Babu said...

Hello Indian,

10.2.0.4 - All oracle bugs fixed. As of now i did not faced any issues.

Please write mail to me in case of any query.

Thanks
Babu
babu.knb@gmail.com

Anonymous said...

Babu,
Excellent post. By following your instructions, I was able to successfully upgrade database from 10.2.0.1 to 10.2.0.4.

Keep up the good work

Mangal

Babu said...

Thanks Mangal

universalcritics said...

that download not working
6810189
can u give other link

Babu said...

Do you have metalink access if Yes pls search

Anonymous said...

Hi Babu,

Your instructions are very helpful. But,Where are he steps 6,7 please tell me them in detail. It could be a great help to me.

Satish Gupta said...

Hi Babu,
I am facing a problem in my application, while executing a query in Oracle 9i (Version Release 9.2.0.1.0)

I am getting Error in my front End application developed in VB 6.0..

run-time error '-21474672599800040050':
[Microsoft][ODBC Driver for Oracle][Oracle]ORA-00600: internal error code, arguments:[20084],[67282756],[47],[67282756],[47],[],[],[]..

This is the error message flashing on my screen.
Please help...

regards,

Satish Gupta said...

Hi Babu,
I am facing a problem in my application, while executing a query in Oracle 9i (Version Release 9.2.0.1.0)

I am getting Error in my front End application developed in VB 6.0..

run-time error '-21474672599800040050':
[Microsoft][ODBC Driver for Oracle][Oracle]ORA-00600: internal error code, arguments:[20084],[67282756],[47],[67282756],[47],[],[],[]..

This is the error message flashing on my screen.
Please help...

regards,

Babu said...

Can I have log pls

rocky said...

hi babu when i tried to download the patch i have been redirected to this link

https://updates.oracle.com/osso_login_success?urlc=v1.2~1DD5A89401BC62EC64D9F7E2867FED4F68D9667A49F1AE2333C57240D0F337E179BF34E555FA76F352E43D9964DBF8958F26BAA87BD5B111FC0C9BC3B1A30C187BC878D2CDF5FA25C141D903A31E03BBBE161D4FCA88F4CE7FA6A2E8ED733CBBEA6FD78B6255687D8BAD64DB51931875EE099E844209EAD9BBC12396D2168CD9C95EAFA12BE84A74A7446A9DD61690CD78B88B06C3FFD166B832956BEEBB1BAA3FDEF4B11ED5F2AB5AFA5731195E7933F18D3079E5A29481745046F150DD52DC4D3700007528D99DC6B2D0F8AB00E67C47A7FC3A893E83A76765CF516CB6F40C7AD188A22142503A0FB34915312F94103A175E057B6602650F1E2091262BB718FF694EB61256C1BF8D6E687CBF2B07A43C3992C1E1AA4646753E23B01CF72472802678857845B1E39D861B83BA31CD9D140011EA842B8031250A4E4B83519A769EAAD0BC16ADFC48EC84C2D67C2A2E1CCD49936146EDB677768E9B0ABC61DF07AFE22BA71E0D4B8642748FE076B4E1BB8D4AF654859A8D9BC722A40163ADCF2A2E32052B236113E8032C9AA02A7EA765AC8ADA9846A25F3FB460B0DECDB8B03375644B23826516B1AEBD59D162512FDD993048FC51E24D4F0F29AAA4158C7C4E12E07B251B9055B45156FF33FFC899D94D1F4918B5BE43DB

access denied why it has popped up this message

Harsha said...

Hi Babu
When I click on download patchset link, I am getting an error "Permission denied for downloading patches from My Oracle Support.". How do I work around this?
Thanks

goutham said...

hi Babu,
This is good explanation about step by step upgrading from oracle 10.2.0.1 to 10.2.0.4.


thanks

goutham said...

hi Babu,
This is good explanation about step by step upgrading from oracle 10.2.0.1 to 10.2.0.4.


thanks
k.goutham

prasad said...

hi babu,
Thanks for your steps of upgrade.
i have one doubt,10.2.0.1 cold backup
restore into 10.2.0.3 next upgrade the patch 10.2.0.0.4.
1)can u send steps.
2)can u provide the name of patch for 10.2.0.1 to 10.2.0.4 upgrade patch no

3)i followed like first uninstall 10.2.0.1 next install 10.2.0.3 and
restore 10201 cold backup,upgrade 10.2.0.4. is it right?

my mail id prasad.lavu@gmail.com

Imran U said...

Very good JOB BABU... I had difficulty to run OEM after patch upgrade from Oracle 10g 10.2.0.1 To 10.2.0.4 almost a week to solve this issue. I followed the instruction and OEM suns successfuly. Thanks Babu